Oracle Sun SPARC Server Quick Configuration
In the following example we’re using a SPARC T4-2. These systems ship from the manufacturer with pre-installed Solaris 11. After the system has been racked and connected to primary and ILO networks, the first step is to configure the ILOM.
You will require a Serial-to-USB adapter and a DB9-to-RJ45 console cable. In this example a Windows 10 laptop is used to connect to the Sun ILOM.
- In Windows Device Manager locate Ports (COM & LPT) -> USB Serial Port
- In PuTTY create Serial connection using COM# from above, baud 9600, terminal emulation VT100
- Initiate connection, hit Enter, login as root:changeme
- At the serial prompt, type the following:
show /SP/network set /SP/network pendingipdiscovery=static set /SP/network pendingipaddress=<server_ip> set /SP/network pendingipgateway=<default_router> set /SP/network pendingipnetmask=<network_mask> show /SP/network set /SP/network commitpending=true set /SP/network state=enabled show /SP/network set /SP hostname=<ILOM_hostname> system_identifier="System description" system_location="Rack, Row, Datacenter, City, State" show /SP start /SYS start /SP/console
The system should boot into the preinstalled image of Solaris. A configuration utility will prompt you to provide basic system information, such as host name, network configuration, and user authentication services. Because direct root login is disabled by default, you will also be prompted to create a personal account.
Basic network configuration
Show physical network interfaces:
# dladm show-phys LINK MEDIA STATE SPEED DUPLEX DEVICE net1 Ethernet up 1000 full igb1 net3 Ethernet unknown 0 unknown igb3 net0 Ethernet up 1000 full igb0 net2 Ethernet unknown 0 unknown igb2 net4 Ethernet up 10 full usbecm2
Show configured network interfaces
# ipadm show-if IFNAME CLASS STATE ACTIVE OVER lo0 loopback ok yes -- net0 ip ok yes -- net1 ip ok yes -- net4 ip ok yes --
Show routing information
# route -p show persistent: route add default 192.168.1.1 -ifp net0 -static persistent: route add default 192.168.2.1 -ifp net1 -static
Show IP configuration
# ipadm show-addr ADDROBJ TYPE STATE ADDR lo0/v4 static ok 127.0.0.1/8 net0/v4 static ok 192.168.1.23/24 net1/v4 static ok 1192.168.1.22/24 net4/v4 static ok 169.254.182.77/24 lo0/v6 static ok ::1/128
Configure network interface “net1”
ipadm create-ip net1 ipadm create-addr -T static -a 192.168.2.23/24 net1/v4 route -p add default 192.168.2.1 -ifp net1 -static
Update default route for interface “net1”
route -p change default 192.168.2.1 -ifp net1
Remove default route for interface “net1”
route -p delete default 192.168.2.1 -ifp net1
Remove network interface “net1”
ipadm delete-ip net1
Configure LACP Link Aggregation
# Create active L4 LACP aggregation of net0 and net1 with MTU of 9000 dladm set-linkprop -p mtu=9000 net0 dladm set-linkprop -p mtu=9000 net1 dladm create-aggr -L active -T short -l net0 -l net1 aggr0 ipadm create-ip aggr0 ipadm create-addr -T static -a 192.168.22.17/24 aggr0 route -p add default 192.168.22.1 -ifp aggr0 -static
Solaris 10/11 allow direct root SSH
cp -p /etc/ssh/sshd_config /etc/ssh/sshd_config.orig ; cp -p /etc/default/login /etc/default/login.orig ; sed 's/PermitRootLogin no/PermitRootLogin yes/g' /etc/ssh/sshd_config > /tmp/sshd_config ; mv -f /tmp/sshd_config /etc/ssh/sshd_config ; chown root:sys /etc/ssh/sshd_config ; chmod 644 /etc/ssh/sshd_config ; sed 's@CONSOLE=/dev/console@\#CONSOLE=/dev/console@g' /etc/default/login > /tmp/login ; mv -f /tmp/login /etc/default/login ; chown root:sys /etc/default/login ; chmod 644 /etc/default/login ; rolemod -K type=normal root ; svcadm restart svc:/network/ssh:default
Configure passwordless SSH
ssh-keygen -t rsa cat /root/.ssh/id_rsa.pub | ssh root@<destination_server> "mkdir /root/.ssh 2>/dev/null; cat >> /root/.ssh/authorized_keys"
Configure ZFS mirror for the root volume
zpool status rpool # Should contain a single disk by default echo | format # record the name of the second disk zpool attach rpool c0t5000CCA054198290d0 c0t5000CCA0541B3668d0 # The original disk name is first, followed by the secondary disk zpool status -lx # Resilvering will take about 10 minutes # after resilvering install bootblock on <second_disk>s0 installboot -f -F zfs /usr/platform/`uname -i`/lib/fs/zfs/bootblk /dev/rdsk/c0t5000CCA0541B3668d0s0 # power off, update boot devices, test alternate disk, reboot from original disk init 0 devalias setenv boot-device disk disk1 net boot disk1 init 0 boot